Unable to set breakpoint

J. Landman Gay jacque at hyperactivesw.com
Tue May 9 16:32:19 CEST 2017


Panos, it wasn't just the tools palette, there was no IDE at all. There 
were no menus except for the default OS X one that allowed me to quit. 
Nothing else loaded, so no message box, tools, keyboard shortcuts, etc. It 
acted like the startup aborted very early in the process. But the odd thing 
was that the start center did appear and when it tried to lead me through 
the tutorial it pointed to places on screen where the nonexistent menus 
would have been. I was able to open my own stack only by dropping it on the 
dock since there was no File menu to use. But without any menus, app or 
project browsers, or tools I couldn't actually do anything with it. The 
entire IDE was missing.

I do still have an old pre-7 prefs file in the same folder as the new one, 
since I need to open LC 6 occasionally. It may be that LC 9 couldn't read 
or update it so it just gave up.

I only have one monitor, and the startup didn't get far enough to load any 
plugins.

--
Jacqueline Landman Gay         |     jacque at hyperactivesw.com
HyperActive Software           |     http://www.hyperactivesw.com



On May 9, 2017 4:06:33 AM panagiotis merakos via use-livecode 
<use-livecode at lists.runrev.com> wrote:

> Hi Jacque,
>
> I have never seen the Tools palette disappearing after deleting my Prefs.
> Could it be the case that it appeared, but offscreen? Have you connected a
> secondary monitor? Are you using any Plugins?
>
> Anyway, I am glad the problem is solved now. If you see that again could
> you please file a bug report?
>
> BTW, I remember in the past, all of a sudden I could not launch *any*
> version of LiveCode. I tried to delete my Prefs but this did not help.
>
> What fixed the problem was deleting the folder /Users/panos/Libarary/Saved
> Application State/com.runrev.livecode.savedState/
>
> Best,
> Panos
> --
>
>
>
>
>
> On Mon, May 8, 2017 at 10:16 PM, J. Landman Gay via use-livecode <
> use-livecode at lists.runrev.com> wrote:
>
>> Okay, restoring prefs from yesterday worked. Major panic averted.
>>
>> But there is something very wrong with a clean startup.
>>
>>
>> On 5/8/17 4:13 PM, J. Landman Gay via use-livecode wrote:
>>
>>> Panos, I need to get this running. I've tried launching dp5 with the
>>> same results. If I restore my old prefs, I can't set breakpoints but I
>>> do get the IDE to load. If I let LC make new prefs, I get no IDE at all
>>> and my only option is to quit.
>>>
>>> On 5/8/17 3:55 PM, panagiotis merakos via use-livecode wrote:
>>>
>>>> Have you tried deleting your Prefs?
>>>>
>>>> On Mon, May 8, 2017 at 9:49 PM, J. Landman Gay via use-livecode <
>>>> use-livecode at lists.runrev.com> wrote:
>>>>
>>>> Suddenly I have lost the ability to set breakpoints. Red-dot breakpoints
>>>>> are dimmed as though the script has not been compiled (it has, several
>>>>> times.) Hard-coded "breakpoint" commands to not trigger either. I am not
>>>>> able to debug.
>>>>>
>>>>> Things were going along well until I allowed remote debugging. That
>>>>> worked
>>>>> for a while, then I got several crashes in a row, and now I can't set
>>>>> breakpoints.
>>>>>
>>>>> I have retarted LC several times, reloaded the stack, etc. LC 9 dp 6.
>>>>>
>>>>> I need a quick solution. Real quick.
>>>>>
>>>>> --
>>>>> Jacqueline Landman Gay         |     jacque at hyperactivesw.com
>>>>> HyperActive Software           |     http://www.hyperactivesw.com
>>>>>
>>>>> _______________________________________________
>>>>> use-livecode mailing list
>>>>> use-livecode at lists.runrev.com
>>>>> Please visit this url to subscribe, unsubscribe and manage your
>>>>> subscription preferences:
>>>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>>>>
>>>>> _______________________________________________
>>>> use-livecode mailing list
>>>> use-livecode at lists.runrev.com
>>>> Please visit this url to subscribe, unsubscribe and manage your
>>>> subscription preferences:
>>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>>>
>>>>
>>>
>>>
>>
>> --
>> Jacqueline Landman Gay         |     jacque at hyperactivesw.com
>> HyperActive Software           |     http://www.hyperactivesw.com
>>
>> _______________________________________________
>> use-livecode mailing list
>> use-livecode at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your 
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the use-livecode mailing list