Compiling LiveCode on Sierra

Brian Milby brian at milby7.com
Sat Jul 29 18:50:27 CEST 2017


Thanks for the pointers.  I was able to get the build working this morning
and confirm what was needed to make the AS Dictionary visible in the build.

Somehow I did get all of my Xcode installs messed up so none would launch
last night.  After I reinstalled 8.3, I ran the script to build the links.
Then I decided that I would rather cache them.  When I deleted the broken
versions of Xcode, I ended up having to relink manually since all of the
SDK links pointed to the old apps instead of the cache.  So, if you want to
cache the SDKs and delete the other copies of Xcode, use the "sh
setup_xcode_sdks.sh -cache" method first.

Thanks again,
Brian

On Sat, Jul 29, 2017 at 4:24 AM, Monte Goulding via use-livecode <
use-livecode at lists.runrev.com> wrote:

> > Recent versions of Xcode have a setting in an internal plist to (by
> default) ignore the 10.9 SDK - this can be solved by:
> >
> > "edit (with Xcode) the MinimumSDKVersion key value in
> /Applications/Xcode.app/Contents/Developer/Platforms/
> MacOSX.platform/Info.plist"
>
> We have a script that does Xcode tinkering in tools/setup_xcode_sdks.sh &
> .py.
>
> PS if you are going to run this against an automagically downloaded from
> the app store version of Xcode you will need to mess with permissions in
> the Xcode app bundle before you do it because you won’t be the owner. Also
> make sure you open Xcode before running the script as the initial setup
> stuff Xcode does must be done first otherwise it bricks the app.
>
> Cheers
>
> Monte
>
>


More information about the use-livecode mailing list