Google Static Maps Demo Available

William Prothero waprothero at gmail.com
Fri Jul 7 04:53:34 CEST 2017


Mark:
Hmmmm…. I checked it out and the problem is with LC 9.0 (dp7). The openstack script is in the first card in the main stack. It has the script to start using the various substacks that are needed. If I open it in LC9, this code somehow gets disabled and doesn’t show in the IDE editor. So, the substacks never get “used.” I tried opening a virgin version in LC 8.1.5(RC3) and it worked as expected. So, I guess this is a bug in the latest LC9 release.

I don’t know about the difficulty entering the APIKey. It works for me in LC8.1.5. lI’m on Mac, latest OS.

The link to get the latest (fixed) download is:
http://earthlearningsolutions.org/google-static-maps-demo/ <http://earthlearningsolutions.org/google-static-maps-demo/>

You need to get this newest version, because I had tested it in LC9 and saved it, so the openstack script was deleted somehow.

I’ll be very interested to see if you have more troubles.

Best,
Bill

> On Jul 6, 2017, at 7:20 PM, Mark Wieder via use-livecode <use-livecode at lists.runrev.com> wrote:
> 
> On 07/06/2017 05:31 PM, William Prothero via use-livecode wrote:
>> Folks:
>> Thanks to help from Hermann, I am sharing a demo stack that accesses the Google Static Maps API to display maps. This API allows me to display a terrain map, and determine the lat/lon values of any point on the map, I will take a snapshot of the map image and draw symbols on it that will represent geophysical data.
>> You can download the demo at:
>> http://earthlearningsolutions.org/google-static-maps-demo/ <http://earthlearningsolutions.org/google-static-maps-demo/>
> 
> Well... erm... not quite sure what I've got going on here.
> 
> I picked up an api key from Google, but I couldn't paste it into the text field. And I couldn't enter more than one character manually. I finally brought up the property editor a couple of times until I could get rid of the single character and then type the api key into the field one character at a time. That seemed to work.
> 
> Went out of edit mode and tried to click on the map. That triggered a script error, so I figured it needed to do some setup stuff (loading libraries, etc) with the api key in place. I saved the stack and quit and reloaded the IDE. I launched the stack again and clicked the 'load map' button. That triggered a series of errors to the point where I finally had to disable messages and shut it all down.
> 
> Obviously I'm missing out on something, but I'm not sure what.
> But it looks like a promising app.
> 
> -- 
> Mark Wieder
> ahsoftware at gmail.com
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode



More information about the use-livecode mailing list