Maybe found another bug in 8

J. Landman Gay jacque at hyperactivesw.com
Tue May 24 21:51:34 EDT 2016


On 5/24/2016 6:58 PM, Bob Sneidar wrote:
> I can no lonegr select the text of a menu button. I would tell you
> what kind of menu button it is but the inspector no longer seems to
> tell me that.

I see the button type in the titlebar on Mac.

> The select command according to the dictionary now only
> works on pictures, not text. That is a BIG deal.

This is what I see in the dictionary when choosing the select command:

select [before | after] {text | chunk} of field
select empty
select objectList

I don't see a reference to images, outside of it being something that 
could be in an objectList.

I do think the new dictionary makes this stuff hard to locate though. 
Typing "select" into the search field shows the line referring to field 
text but you actually have to click on it to see the rest of the syntax 
options. Just scanning the hit list wouldn't give you the idea there was 
more to it.

> Several of my menus
> work this way. As the user types, I filter down the menu options that
> begin with what the user has already typed, so that he can type 2 or
> 3 characters and the list will be a few items long instead of the
> original several hundred.

Have you tried the menuhistory? That's the recommended way to set a menu 
selection. Get a line offset of the user's text and set the menuhistory 
to that number.

That said, I just tried selecting the text of an option menu and it 
works as expected here. You've seen a few other anomalies today, it 
sounds like something is interfering with normal operation.

-- 
Jacqueline Landman Gay         |     jacque at hyperactivesw.com
HyperActive Software           |     http://www.hyperactivesw.com




More information about the Use-livecode mailing list