[ANN] Release 8.0.0

Warren Samples warren at warrensweb.us
Thu May 5 23:55:56 CEST 2016


On 05/04/2016 09:12 AM, Peter TB Brett wrote:
> Dear list members,
>
> We are pleased to announce the release of LiveCode 8.0.0, the first
> stable release of LiveCode 8.


I'm running openSUSE Leap 42.1 here and finding that Livecode 8 will not 
launch. The installer worked properly. Launching LiveCode displays the 
splashscreen followed either by a rapid crash (IDE itself never 
displays) or a permanent hang at the splashscreen. Running it from the 
command line results in this:

"Use of deprecated SAXv1 function setDocumentLocator
*** Error in 
`/home/warren/.runrev/components/livecodecommunity-8.0.0.x86_64/livecodecommunity.x86_64': 
free(): invalid next size (fast): 0x0000000003d3b820 ***" at the top of 
the full backtrace.

I had been running openSUSE 13.2 until recently and hadn't had this kind 
of difficulty with the dps and the RC of version 8. Under Leap, however, 
I get this same undesired behavior with the  v8 RC. LC versions 6 and 7 
work fine.

Deleting prefs and licenses has no effect.

Any thoughts on what I might be able to install to correct this? (Or, 
what LiveCode might be expecting to find which may or may not be 
available for installation in my distro...)

Warren



More information about the use-livecode mailing list