server difficulties coming from LC7, or new host?

Phil Davis revdev at pdslabs.net
Wed Mar 16 23:50:24 EDT 2016


Submitted as bug #17153


On 3/16/16 11:46 AM, David Simpson wrote:
> Phil,
> Did you open a support ticket? I have found LiveCode to be very responsive.
>
> It would potentially be helpful for them to see a simple recipe stack which duplicates the problem. Maybe there is some global config parameter which needs changed - and they could test and resolve it very quickly.
>
> David Simpson
> www.fmpromigrator.com
>
>
>
>> On Mar 16, 2016, at 11:37 AM, Phil Davis <revdev at pdslabs.net> wrote:
>>
>> Hi folks,
>>
>> Summary:
>> Since diesel was moved to the new hosting provider last weekend, my main customer's relatively stable client/server system no longer works. I'm trying to understand why. (The server code is in my customer's on-rev account, not on a LAN server.)
>>
>> I have adjusted arrayEncode() in my server code to work with my 6.x client apps, but this has not been enough to make everything work again. The apps are able to interact with server code enough to get authenticated as valid users of the system, but any attempt by an app to download a data chunk of 200k or so causes timeout errors, even if I set client and server socketTimeoutIntervals to a ridiculously long 60 seconds. (My server tests show that the server is done with the 'put' loooong before the client 'post' times out.) Communication from clients to server use 'post' or 'get', and the server code 'puts' all data back to clients.
>>
>>
>> Details:
>> Each of 3 desktop apps reaches out to the code in my customer's on-rev (now LC) hosting account for authentication and data before proceeding. Then in the course of doing their jobs, they will upload or download other info.
>>
>> With the advent of the new hosting provider, we were also given LC 7.1.0 as our only choice of server engine. This in itself is not a bad thing, but it immediately impacted my world. I had to change all instances of "arrayEncode()" in my server code to include the "6.7" param since all our desktop apps are currently built with LC 6.x. (Our transfer data is often structured in arrays underneath the encoding.) For a full 10 seconds or so after that change, I thought our problems were solved, but it only allowed the next problem to manifest itself.
>>
>>
>> I'm probably leaving out some vital info, so feel free to ask. I'm getting nowhere right now, so I'll greatly appreciate any insight you can offer. I would love to discover that I'm overlooking something simple. (Hey, I can always hope!)
>>
>> Thanks -
>>
>> -- 
>> Phil Davis
>>
>>
>> _______________________________________________
>> livecode-dev mailing list
>> livecode-dev at lists.runrev.com
>> http://lists.runrev.com/mailman/listinfo/livecode-dev
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>

-- 
Phil Davis





More information about the Use-livecode mailing list