htmlText not supporting target in <a href="xxx">?

Mike Bonner bonnmike at gmail.com
Tue Jun 21 01:49:42 EDT 2016


You'd have to code a method to do what you want using linkclicked. When a
text link in a field is clicked it fires a linkclicked message with one
parameter that contains the link text. If you want to place the contents of
the url into a different field, something like this in the field handler.

on linkclicked pUrl
     put url pUrl into field "destinationField"
end linkclicked

If I remember right, you must have the text of the field locked for this to
work.

On Mon, Jun 20, 2016 at 8:28 AM, Klaus major-k <klaus at major-k.de> wrote:

> After reading this a second time, it looks I have misunderstood the actual
> problem, sorry...
>
> > Am 20.06.2016 um 15:41 schrieb Klaus major-k <klaus at major-k.de>:
> >
> > Dag Ton,
> >
> >> Am 20.06.2016 um 15:22 schrieb tkuypers at telenet.be <
> tkuypers at publishingtools4u.com>:
> >>
> >> Is this a bug or am I missing something?
> >>
> >> I pasted the following URL into a field:
> >>
> >> <p>click <a href="
> http://www.malamix.be/ClientData/88/234/35691/1313/1/Flyer%20Malamix%20Food%20Nederlands.pdf
> <
> http://www.malamix.be/ClientData/88/234/35691/1313/1/Flyer%20Malamix%20Food%20Nederlands.pdf>”>here</a>
> for the full specs </p>
> >>
> >> Using a click on a button, I enter this into another textfield, where
> it shows as htmlText, so the link is invisible and the “here” is underlined
> and blue.
> >>
> >> (The field contains more info, which will be shown in a webshop which
> I’m filling with data.)
> >>
> >>
> >> Switching the field back and forward between html and the actual code
> works fine.
> >> But I need to show the link in a new window, so I add “ target=‘_blank’
> “ after the link:
> >> <p>click <a href="
> http://www.malamix.be/ClientData/88/234/35691/1313/1/Flyer%20Malamix%20Food%20Nederlands.pdf
> <
> http://www.malamix.be/ClientData/88/234/35691/1313/1/Flyer%20Malamix%20Food%20Nederlands.pdf>”
> target=‘_blank'>here</a> for the full specs </p>
> >>
> >> And when I switch between the visual text and the html-code, the
> target-part is gone…
> >>
> >> I’m using LC 0.01, but the same result in 8.02 rc2.
> >>
> >> Bug or “hidden feature”?
> >
> > as far as I remember, and that goes back to MetaCard 2.0 :-), this has
> never been working
> > out of the box unless you add a "on linkclicked tLink..." handler to the
> fields script.
> >
> >> Met vriendelijke groeten,
> >> Warm Regards,
> >>
> >>
> >>
> >> Ton Kuypers
> >> +32 (0) 477 739 530
> >>
> >> Steenweg op Leopoldsburg 100 • B-2490 • Balen • Belgium
> >> www.publishingtools4u.com <http://www.publishingtools4u.com/>
> >
> > Groetjes
> >
> > Klaus
> >
> > --
> > Klaus Major
> > http://www.major-k.de
> > klaus at major-k.de
> >
> >
> > _______________________________________________
> > use-livecode mailing list
> > use-livecode at lists.runrev.com
> > Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
>
> --
> Klaus Major
> http://www.major-k.de
> klaus at major-k.de
>
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>



More information about the Use-livecode mailing list