"could not find a valid identity to use for the selected profile"

Ben Rubinstein benr_mc at cogapp.com
Thu Feb 18 18:18:43 EST 2016

Aaaagh. It was working (I was building an app and deploying it to a device)... 
now it's not, with the infuriating message from the subject line.  Xcode can 
still build a (different) app and deploy it to the same device.

What's changed in the interim?  I've added some other devices in the Developer 
Center; nothing else I can think of.

This happened before, I don't know how I fixed it - because I flailed around 
for days, trying many things.

Is there a known voodoo dance I can do?  Is there some clean way to reset 
things and start again? Is there some way to force LiveCode to flush and 
reload profiles? Or is that not the problem?

This is using LC 7.1.1 with Xcode 7.1.1 (rare moment of co-incidence).  I've 
tried using LC 7.1.2 rc 2 with Xcode 7.2, that just adds more other kinds of pain.

Please help or send drugs,


More information about the use-livecode mailing list