QT and LC 5.5.5; Which LC should I update to?

Devin Asay devin_asay at byu.edu
Thu Feb 26 22:33:07 CET 2015


On Feb 25, 2015, at 9:11 PM, Charles Szasz <cszasz at me.com> wrote:

> 
> I am currently using 5.5 to make Mac apps that do not employ QT. I am also started using App Wrapper 3. I noticed that each app that I code signed for the Mac I have to always to designate not to include QT as an exec.  
> 
> I received emails from Sam Rowland, the creator of App Wrapper about this problem. He pointed out that the version of LC (5.5.5) has QT wired into this version.  He suggested that since QT has been depreciated in OS X and depends on Carbon that this will crash Mac apps. Although I have yet to have an app crash on Mavericks, which I used for development, I am concerned about this issue.
> 
> So here is my question:  Which LC version should I update to that is stable and does not depend on Carbon? Again, I am not interested in QT or AV Foundation since I do not use these in my apps.

Charles,

I’d go with the latest stable version of 6.7, since it has been more fully extricated from its dependence on QT. If you need unicode support go with 7.0.x

My $.02.

Devin

Devin Asay
Office of Digital Humanities
Brigham Young University




More information about the use-livecode mailing list