QT and LC 5.5.5; Which LC should I update to?

Charles Szasz cszasz at me.com
Wed Feb 25 23:11:50 EST 2015


I am currently using 5.5 to make Mac apps that do not employ QT. I am also started using App Wrapper 3. I noticed that each app that I code signed for the Mac I have to always to designate not to include QT as an exec.  

I received emails from Sam Rowland, the creator of App Wrapper about this problem. He pointed out that the version of LC (5.5.5) has QT wired into this version.  He suggested that since QT has been depreciated in OS X and depends on Carbon that this will crash Mac apps. Although I have yet to have an app crash on Mavericks, which I used for development, I am concerned about this issue.

So here is my question:  Which LC version should I update to that is stable and does not depend on Carbon? Again, I am not interested in QT or AV Foundation since I do not use these in my apps.


Sent from my iPad



More information about the Use-livecode mailing list