mouse pointer hot spot is way off

J. Landman Gay jacque at hyperactivesw.com
Sat Aug 15 20:31:16 CEST 2015


In addition to the tests that Mike suggested, it would be interesting to 
see what you get back if you ask for the mouseloc in the message box 
when you see the problem. Put the cursor up near the 0,0 point of the 
editor so you have a visual reference.

I do like the term "Gatsby bug." :)


On 8/15/2015 11:39 AM, Dar Scott wrote:
> It doesn’t feel like a 3rd party mouse issue to me, but that is only because the problem is limited to LiveCode stack content.  (I have a Macally EcoMouse hooked up at the moment.)
>
> This occurs in the content of some LiveCode windows.  I don’t think I’ve ever seen it outside of that.  It most often shows up in the editor, but I’ve seen it in a stack I’m creating.  Such a stack might have buttons, fields and option menus on it.
>
> It doesn’t feel like an IDE thing to me, but I hope it is.  That is, I don’t want to see this in a standalone.  Maybe the IDE sometimes uses or modifies a cursor image?
>
> I’m not now working on cursors or image hotspots or Windows menus or anything like that, so I don’t think it is my code that is doing anything.
>
> This happened on Mavericks and then on the same machine upgraded to Yosemite.
>
> I am not sure, but I think one time i had to restart OS X.  I have trouble believing that.  However it might be a Gatsby Bug, involving both LiveCode and OS X.  (I made up that term.  In The Great Gatsby, a lady says accidents occur when two bad drivers enter the same intersection.)
>
> Dar
>
>
>
>> On Aug 15, 2015, at 9:58 AM, J. Landman Gay <jacque at hyperactivesw.com> wrote:
>>
>> On August 15, 2015 9:58:45 AM CDT, "Dr. Hawkins" <dochawk at gmail.com> wrote:
>>> On Sat, Aug 15, 2015 at 7:37 AM, Dar Scott <dsc at swcp.com> wrote:
>>>
>>>> Very often the hot spot is off, usually about 50-100 pixels high, for
>>> one
>>>> or more windows in the IDE.  I usually notice it in the editor where
>>> it is
>>>> off by 3 lines.  Almost always it is just vertical.
>>>>
>>>
>>> I see this on a regular basis in 7.
>>
>> I haven't seen it yet. Are those who have seen it using a third-party mouse?
>> --
>> Jacqueline Landman Gay         |     jacque at hyperactivesw.com
>> HyperActive Software           |     http://www.hyperactivesw.com
>>
>> _______________________________________________
>> use-livecode mailing list
>> use-livecode at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>


-- 
Jacqueline Landman Gay         |     jacque at hyperactivesw.com
HyperActive Software           |     http://www.hyperactivesw.com




More information about the use-livecode mailing list