HTPPS problem with a web service

David Bovill david.bovill at gmail.com
Wed Apr 23 14:35:48 CEST 2014


I'm having an https problem with a RESTful web service I am calling. Here
is the url (which works in the browser but not from the IDE):

https://api.dreamhost.com/?key=6SHU5P2HLDAYECUM&cmd=user-list_users_no_pw&unique_id=4082432&format=perl


I've tried libUrlSetSSLVerificition false and made a stab at debugging it.
I get the following error:

httpproxyforurl for host 'api.dreamhost.com':
> Proxy for URL:
> socket selected: api.dreamhost.com:443|6924
> GET
> /?key=6SHU5P2HLDAYECUM&cmd=user-list_users_no_pw&unique_id=4082432&format=perl
> HTTP/1.1
> Host: api.dreamhost.com
> User-Agent: curl/7.30.0
> Accept: */*
> socket timeout api.dreamhost.com:443|6924


And the following headers sent (as you can see I tried changing the user
agent as curl works fine):

GET
> /?key=6SHU5P2HLDAYECUM&cmd=user-list_users_no_pw&unique_id=4082432&format=perl
> HTTP/1.1
> Host: api.dreamhost.com
> User-Agent: curl/7.30.0
> Accept: */*
>

And returned:


> HTTP/1.1 200 OK
> Set-Cookie: 60gpBAK=R1224191420; path=/; expires=Mon, 07-Apr-2014 18:14:08
> GMT
> Date: Mon, 07 Apr 2014 17:06:53 GMT
> Content-Type: text/html; charset=utf-8
> Transfer-Encoding: chunked
> Connection: keep-alive
> Set-Cookie: 60gp=R477302024; path=/; expires=Mon, 07-Apr-2014 18:08:19 GMT
> Server: Apache
> X-Powered-By: PHP/5.2.17
> Vary: Cookie,Accept-Encoding
> Composed-By: SPIP 2.1.24 @ www.spip.net + images(1.0.1),
> msie_compat(1.0.0), porte_plume(1.7.9), safehtml(1.3.7), vertebres(1.0.0),
> guestbook(2.22), compresseur(1.0.2)
> X-Spip-Cache: 86400
> Last-Modified: Mon, 07 Apr 2014 17:06:53 GMT


Any thoughts?


More information about the use-livecode mailing list