Sending mail from on-server

Andrew Kluthe andrew at ctech.me
Thu Oct 3 16:40:25 CEST 2013


It's not entirely free but I use a service called Postmark to send emails
for me so that they are less likely to hit spam folders.

It is basically an email delivery system that can use a REST api for
sending mails. You get 1000 credits when you sign up for free and can
purchase more credits for 1.50 per thousand emails.

Most of my emails get sent out from my backend now, but Im sure I still
have a postmark library laying around. If I can't find it, I would be happy
to flesh out the basics again real fast.



On Thu, Oct 3, 2013 at 6:30 AM, Roger Eller <roger.e.eller at sealedair.com>wrote:

> It's also possible that your server needs an email server service
> installed, or at least configured.
>
> ~Roger
> On Oct 3, 2013 5:13 AM, "Dave Kilroy" <dave at applicationinsight.com> wrote:
>
> > Hi Christer
> >
> > I also think there is a problem with access to shell via on-rev (I'm on
> > pancake)
> >
> > About a week ago I was messing around with Business Academy Lesson 53
> > (using
> > LiveCode Server and Post to relay an email) and couldn't get anywhere.
> The
> > server-side script and app were both pretty much exactly the same as in
> the
> > lesson; specifically I would post up to the server like this:
> >
> > post theSubject & "&" & theFrom & "&" & theMessage to URL \
> > "http://applicationinsight.com/apps/email/newvehicle.lc"
> >
> > And then directly after check 'it' - which did not return an error. So my
> > local app thinks everything is OK - but no email gets sent.
> >
> > The server-side script I'm using is a more-or-less copy from this lesson
> >
> >
> http://lessons.runrev.com/s/lessons/m/4070/l/8184-sending-emails-from-livecode-server-scripts
> > <
> >
> http://lessons.runrev.com/s/lessons/m/4070/l/8184-sending-emails-from-livecode-server-scripts
> > >
> > (but with an added line "if the result is not empty then put the result"
> as
> > recommended by Kevin in the accompanying Lesson 53 video
> >
> > Interestingly, during my debugging attempts I once sent the POST message
> by
> > mistake to the address in the lesson (runtime.on-rev.com) and straight
> > away
> > got a CC copy of the email in my inbox - so it works just fine on other
> > servers - just not on mine.
> >
> > So SOMETHING is wrong with access to shell on the server (my current
> theory
> > is that they need to authorise access to it on an individual basis and
> I've
> > never tried to use it before). Christer did you by any chance get moved
> to
> > pancake recently? If so could it be an authorisation issue?
> >
> > By the way I emailed support at on-rev about a week ago and apart from the
> > automated reply never heard any more from them...
> >
> > Can any of you shed some light?
> >
> > Kind regards
> >
> > Dave
> >
> >
> >
> > --
> > View this message in context:
> >
> http://runtime-revolution.278305.n4.nabble.com/Sending-mail-from-on-server-tp4670581p4670583.html
> > Sent from the Revolution - User mailing list archive at Nabble.com.
> >
> > _______________________________________________
> > use-livecode mailing list
> > use-livecode at lists.runrev.com
> > Please visit this url to subscribe, unsubscribe and manage your
> > subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
> >
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>



-- 
Regards,

Andrew Kluthe
andrew at ctech.me


More information about the use-livecode mailing list