testing installer pkg for App Store

Lars Brehmer larsbrehmer at mac.com
Mon Mar 11 09:02:13 EDT 2013


OK, this is a little bit spooky!

Once again I am testing for app store submission, using the Mac App Submit article in RevUp June 17th 2011.

I did this a few weeks ago for the first time and got help solving an initial problem. It worked. Now I am back at it with a new problem.

After a few tries I successfully got the .pkg file, put a copy of it on my desktop and ran the "sudo installer -store -pkg" in terminal. The result looked good. In the terminal, these lines were among the results;



installer: Installation Check: Passed

installer: Volume Check: Passed

and;

installer: Starting install

installer: Install 0.0% complete

installer: Install 28.9% complete

installer: Install 100.0% complete

installer: Finished install



so it looked pretty good, right?

But to my surprise, there was no application in my applications folder! So I double clicked on the installer package, which did everything I expected from an OSX installer, including the chime and the message "Aplication successfully installed" at the end.

But again, still no application the the applications folder!

I also looked into my user applications folder, but nothing!

I can hardly submit an app that doesn't show up ;-)

The only difference between now and when it worked a few weeks ago is that I upgraded to LiveCode 5.5.4, but surely that can't be the problem or it would have appeared in this forum a long time ago.

Any ideas? This really has me spooked!

Cheers,

Lars





More information about the Use-livecode mailing list