Copying from MS word into RunRev 4.0

Keith Clarke keith.clarke at clarkeandclarke.co.uk
Fri Sep 2 15:08:48 EDT 2011


I'm confused, how do you know the characters are missing until you paste the clipboard contents somewhere within LC to render them and see them?

If you 'test' by rendering any formatted text into a field, you get the field's behaviour of partial interpretation of some text formatting in your test data. However, if you test by rendering into a custom property (or file) you will not get the field's artefacts added to the clipboard data.

I hope that helps.
Best,
Keith..   


On 2 Sep 2011, at 19:59, Jonathan Lynch wrote:

> Hi Keith,
> 
> The characters are entitely absent from the clipboarddata["html"] and every
> other element of the clipboard array.
> 
> Are there other means of accessing the clipboard besides using the
> clipboarddata or paste operations?
> 
> On Fri, Sep 2, 2011 at 2:48 PM, Keith Clarke <
> keith.clarke at clarkeandclarke.co.uk> wrote:
> 
>> It might be worth avoiding pasting into an LC field (LC fields can be
>> awkward when working with formatted text such as HTML/XML as they interpret
>> some tags). It might be worth an experiment to
>> 1) paste the clipboard contents into an LC variable, instead of a field
>> 2) set custom property to the variable and then
>> 3) view the custom property in the Property inspector - to see if you get
>> any characters or blanks
>> 
>> That way you'd know if the problem is with the LC paste function (a
>> potential engine bug) or simply a field rendering one (a problem I get with
>> HTML and XML tags all the time).
>> Best,
>> Keith..
>> 
>> On 2 Sep 2011, at 18:51, Jonathan Lynch wrote:
>> 
>>> I just tried it, but no success.
>>> 
>>> I copied a bunch of apostrophes from Word, and used a button that puts
>> the
>>> clipboarddata["html"] into a field. All the field shows is "<p></p>" -
>> all
>>> of the apostrophes were omitted, even though I can paste them into
>> Notepad.
>>> 
>>> Do you have any other suggestions? I will try them all.
>>> 
>>> Unfortunately, all elements in the clipboarddata array do not have the
>>> missing characters - I tried them.
>>> 
>>> I just worked out a technique using VBScript and IE rather than Word, and
>> it
>>> works fine, but is no faster than the method I was using with Word.
>>> 
>>> Are there any externals available that might be useful?
>>> 
>>> On Fri, Sep 2, 2011 at 1:10 PM, J. Landman Gay <jacque at hyperactivesw.com
>>> wrote:
>>> 
>>>> On 9/2/11 10:21 AM, Jonathan Lynch wrote:
>>>> 
>>>>> Hi everyone.
>>>>> 
>>>>> When I type this word into MS Word: it's
>>>>> 
>>>>> Then copy and paste it into a field in RunRev, the apostrophe gets
>>>>> omitted.
>>>>> This is on a windows system. The character in question is not the usual
>>>>> apostrophe, but is the curly apostrophe that MS Word uses.
>>>>> 
>>>> 
>>>> I haven't tried it, but it might be possible to trap the pasteKey
>> message
>>>> and instead of pasting directly, set the htmltext of the selection to
>> the
>>>> clipboard["html"]. Maybe Word inserts character entities that LiveCode
>> can
>>>> read.
>> 
>> 
>> _______________________________________________
>> use-livecode mailing list
>> use-livecode at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>> 
> 
> 
> 
> -- 
> Do all things with love
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the Use-livecode mailing list