Codesign Error

Marty Knapp martyknapp at comcast.net
Thu Jan 13 11:19:16 EST 2011


Hey Colin,

My app doesn't have a data folder in the bundle, so it didn't do that 
step. The codesign command you suggested is exactly what I tried. As 
that didn't work, I didn't get any further.

I need to get to the bottom of what "no identity found" is referring to 
- I'm assuming that it's either a certificate problem or a plist 
problem, though that's just a guess on my part.

I tried the "Signing Assistant" program that you can download from the 
Rev newsletter of a few issues ago, in the article, 'LiveCode Apps for 
the Mac Store" but it isn't working for me either. I assume it's running 
into the same problem, though it does not appear to have any error 
reporting.

I'm pretty new to using the Terminal and it seems to me that Apple 
should supply something a bit better for a routine task like this. Or do 
the codesigning themselves when you upload your app.

So I'm stuck at this point. I've sent tech support questions to Apple in 
the past and I've never gotten a response, so haven't done that with 
this issue.

Marty
> Here are steps that someone doing a Unity app succeeded with, there may be something in the lines that stands out as being different to what you're doing:
>
> Permissions - Change permissions of Unity's Data folder - it has to get read rights for "everyone"
> chmod -R a+xr "Bubble Bang.app/Contents/Data"
>
> Code Signing:
> codesign -f -s "3rd Party Mac Developer Application: Martin Schultz" "Bubble Bang.app"
>
> Build package:
> productbuild --component "Bubble Bang.app" /Applications --sign "3rd Party Mac Developer Installer: Martin Schultz" --product "Bubble Bang.app/Contents/Info.plist" BubbleBang.pkg
>
> Testing:
> sudo installer -store -pkg "BubbleBang.pkg" -target /
>




More information about the Use-livecode mailing list