Possible data grid bug?

Bob Sneidar bobs at twft.com
Sat Feb 27 17:02:23 EST 2010


Hi Jeff. 

The only place you can use "of me" is in the script of the DG object itself. If the script you are setting the dgText is in another object, then you have to use "of group <datagridname>". If you call it from another card, then you have to add the reference of the card: "of group <datagridname> of card <nameofcardthedatagridison>". If you still throw errors, you may have uncovered a bug with behaviors. 

Bob

On Feb 27, 2010, at 12:55 PM, Jeff Massung wrote:

> I have an interesting situation here, and likely this is just a bug on my
> end, but thought I'd toss it out and see if maybe it's not me. Essentially,
> I'm trying to fill in data for a data grid that's on another card that isn't
> the current card.
> 
> I'm using "of me" everywhere and - in fact - all my data does get added to
> the DG. But a whole lot of exceptions are thrown from elsewhere (deeper in
> the DG behavior), causing sections of my code to not execute. Result: bugs.
> If I switch cards first, then dispatch the commands, no exceptions are
> thrown.
> 
> Anyone else tried this before or have any ideas what might be causing my
> issues?
> 
> Jeff M.
> _______________________________________________
> use-revolution mailing list
> use-revolution at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution




More information about the Use-livecode mailing list