stack crashing IDE

Bernard Devlin bdrunrev at gmail.com
Thu Feb 18 09:15:44 EST 2010


On Vista, I went to open a stack that I haven't looked at for a few
weeks.  But as soon as I try to open it, the IDE crashes.

No popup from Rev to say that the stack is corrupted.  Sometimes I am
able to get a crash warning from the OS:

Problem Event Name:	APPCRASH
  Application Name:	Revolution.exe
  Application Version:	4.0.0.950
  Application Timestamp:	4af84e48
  Fault Module Name:	Revolution.exe
  Fault Module Version:	4.0.0.950
  Fault Module Timestamp:	4af84e48
  Exception Code:	c0000005
  Exception Offset:	0008e720
  OS Version:	6.0.6002.2.2.0.768.3
  Locale ID:	2057
  Additional Information 1:	fd00
  Additional Information 2:	ea6f5fe8924aaa756324d57f87834160
  Additional Information 3:	fd00
  Additional Information 4:	ea6f5fe8924aaa756324d57f87834160

I have used this stack many times throughout January 2010, and as far
as I can remember, there was no problem the last time I was using it.
Furthermore, I haven't updated Rev in months.

The only thing I can think that might cause something like this, is
that the stack makes use of some externals: Valentina and revBrowser.
I haven't changed anything to the Valentina install since the
beginning of January, long before I was using this stack.  And if I
open up the Valentina sample stack, there is no problem using
Valentina.  Using VStudio I can open the valentina db the stack
references. So it doesn't look like the issue is with Valentina.  I've
checked the browser sampler stack, and that opens a browser window, so
it doesn't look like revBrowser is the problem either.

I've set lockMessages to true before opening the stack, but still the
IDE crashes.

Any suggestions as to how I can find out more about what is going on?
There is the Vista crash log, but there's nothing in there that I can
make use of.

Bernard



More information about the Use-livecode mailing list