windows, copy, past and right mouse button

sales at dynamechdesign.com sales at dynamechdesign.com
Wed Aug 25 04:43:56 EDT 2010


Johathan,

Mark helped me quite a bit on the forum page. I did try to implement
that script in my stack. I modified a copy of the Rev 'ask' stack but
wasn't sure how to merge it into my stack to use in place of the default 
stack.
What I did was a little against the rules and worked around using the 'ask' 
dialog
with hiding and showing buttons and fields for the user to enter his 
username
and password. If he 'right-clicks' on the empty field it automatically 
checks
to see if text is in the clipboard and if true then pastes it in for him. I 
figured if
someone is clicking in a blank field the only reason to do so would be to 
paste
something in there. No need for a popup menu, which I got frustrated trying
to implement. I will have to practice using that somewhere else. I was in a
time crunch to get a functional program to a customer.

Bruce

----- Original Message ----- 
From: "Jonathan Lynch" <jonathandlynch at gmail.com>
To: "How to use Revolution" <use-revolution at lists.runrev.com>
Sent: Tuesday, August 24, 2010 10:37 AM
Subject: Re: windows, copy, past and right mouse button


> on mouseUp tButton
>  if tButton = 3 then
>  answer "The right mouse button is button number 3"
>  end if
> end mouseUp
>
> does that help?
>
> On Fri, Aug 20, 2010 at 8:35 PM, <sales at dynamechdesign.com> wrote:
>
>> Being a relative newbie, I've looked and searched through the files but 
>> am
>> unable to figure out how to incorporate the right mouse button into my
>> scripts. As I have been forced to use Windoze computers for quite a 
>> while, I
>> have gotten used to using the right mouse button to do copy and pasting 
>> of
>> text. I have written several stacks the latest of which I need to enter a
>> UserName and Password. I have a program that stores my passwords and such
>> and frequently use it to copy and paste from, but when I right click on 
>> the
>> "Enter Username:" dialog box, nothing happens. I can however use the
>> keyboard shortcut ctrl-v which works as long as I'm running Rev. If I 
>> build
>> a standalone, even that doesn't work. I'm not sure if the problem exists
>> because the answer command is a blocking command or not. Thanks in 
>> advance
>> for your help. Sorry so wordy.
>>
>> Bruce
>> _______________________________________________
>> use-revolution mailing list
>> use-revolution at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-revolution
>>
>
>
>
> -- 
> Do all things with love
> _______________________________________________
> use-revolution mailing list
> use-revolution at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your 
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution 




More information about the Use-livecode mailing list