Re-7: libeay32.dll error with standalone

runrev260805 at m-r-d.de runrev260805 at m-r-d.de
Mon Mar 30 13:40:30 EDT 2009


Hi Jim,

i am running a 32-bit system.

The problem is, that the standalones  looks at startup if it can find a libeay32.dll in windows or any folder defined in %path%, although the standalone, even the standalone with just one answer dialog, is created with settings,that do not include the ssl library. My problem is/was, that my customer owns about 50 Acer pc´s, which all have installed Acer´s eDataSecuritySoftware. This software extend  %path% to a i386 and a x86 folder of within the eDataSecurity folder

My standalone, which does not use ssl, looks now along the path if it can find the libeay32.dll. It finds it in i386 and also in x64 and tries to load it. Then i get an errormessage, but this message is not generated by the standalone. I think that message is created by windows, because the standalone tries to load a 64-bit version of libeay32.dll under 32-bit windows. And that cannot work. Btw. if i rename the libeay32.dll in folder x64. The standalone starts up without any error message.

But again, why does a Revolution standalone, which does not use any ssl or encryption,  looks for and tries to load  the libeay32.dll? What for?  That´s what i do not understand.

If you are interested, i can send you the specific libeay32.dll, which produces the error here. Just replace it with your one, run a standalone with only an anwwer dialog and you will see what i mean.


Regards,

Matthias



-------- Original Message --------
Subject: RE: Re-5: libeay32.dll error with standalone (30-Mrz-2009 17:36)
From:    Jim Bufalini <jim at visitrieve.com>
To:      runrev260805 at m-r-d.de

> Hi Matthias.
> 
> > 
> > > I believe, if you A. Remove SSL & Encryption from your Standalone
> > > Application Settings or, B. Build your standalone with Studio,
> > Revolution
> > > will not look for these libs.
> > >
> > 
> > Thanks for your reply, but I am really sorry to dissapoint you. ;-)
> > 
> > But both suggestions do not work.
> > 
> > A. Although without SSL Library selected in Standalone settings (i
> > manually selected only Answer dialog and none library) the standalone
> > looks for the libeay32.dll and tries to load it. Because it only finds
> > the 64 bit one, windows creates this error message.
> > 
> > B. Even the standalone created with Studio 3.0 does so.
> > 
> > 
> > To avoid such messages at the customers side, i have to include the
> > libeay32.dll with my standalone. No other way, at least until now.
> 
> 
> Hmmm... Maybe this is Windows 64 issue? 
> 
> Because I responded to both you and tested and responded to a: *Can anybody
> HELP!!* post that required I build a Standalone of a stack with only an
> answer button in it in a protected 3.0 stack, I was able to quickly test.
> 
> 1. I shut down Rev apps I use that I know use encryption.
> 2. I renamed libeay32.dll and ssleay32.dll to _libeay32.dll and
> _ssleay32.dll in my Windows\System32 directory (where I decided, two-years
> ago, to stick them).
> 3. I did a search of my hard drive for other copies of these files. There
> are none.
> 4. I ran the programs that require these libs. They crashed all over the
> place!
> 5. OK... the libs are missing.
> 6. Confirmed that the EXE that I created to test an Answer command in a 3.0
> stack and locked Standalone build does not have these libs where they MUST
> be, which is in the root directory or the EXE or in the IDE, it's root
> directory, or in the System32 directory.
> 7. Ran that EXE. It worked fine.
> 
> This was all tested on Windows Vista Home Premium and Rev 3.0.
> 
> Do you have the ability to test on a 32-bit Windows system? If not, send me
> you app off-list and I will test here.
> 
> Now I need to reconfigure my system again, so that the apps I run daily
> don't crash. ;-)
> 
> Aloha from Hawaii
> 
> Jim Bufalini
> 
> 
> 
> _______________________________________________
> use-revolution mailing list
> use-revolution at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your 
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution
> 
> 
> 
> 
> To: use-revolution at lists.runrev.com





More information about the Use-livecode mailing list