DataGrid: mouseup stops working after setting dgProp["default column behavior"]: Reloaded

klaus at klaus at
Wed Apr 29 10:38:56 EDT 2009

Hi Trevor,

> On Apr 29, 2009, at 9:33 AM, klaus at wrote:
>> I posted this yesterday, but did not get an answer yet.
>> If someone can give a hint or two, please do it :-)
>> This is blocking our current project.
> I don't think the other email ever came through.
>>> Hi all, as the subject states, mouseup stopped working in my  
>>> DataGrid.
>>> Using the arrowkeys to navigate still works fine.
>>> I added this custom behaviour via a new button, which works as  
>>> exspected
>>> (converts the data to Mac encoding if necessary and urldecodes the  
>>> data):
>>> on FillInData pData
>>>  set the text of me to win2mac(urldecode(pData))
>>> end fillInData
>>> But after that navigating in the list with the mouse stopped  
>>> working?!
>>> Setting the custom behaviour to empty again does not resolve the  
>>> problem,
>>> I just cannot click to change the list.
>>> I already quit and reopened Rev/MetaCard, still no joy. Any hints?
>> I also found out that this only happens if the stack with the grid  
>> is a substack!!!???
>> NO problems if that stack is a mainstack.
>> I already filed a bug report, but we definitivley cannot wait for  
>> that one to be fixed ;-)
>> <>
> I read the bug report and my first question is whether or not this  
> bug only happens in the standalone?
> Based on your bug report it appears that you are building a  
> distribution and then afterwards the mouseup message stops working.

No, sorry for the confusion, this also happens in the IDE.
We did not make a distribution/standalone yet. This has to work  
first ;-)

> It sounds likes there may be a behavior bug of some sort. Have you  
> tried recreating the data grid on the substack from scratch?

Yes, started with a fresh stack and experienced the same.
No problems if the stack is a mainstack, see below...

> Another thing to do is to add some logging functions to the arrowkey  
> and mouseUp messages in button "Data grid" of stack  
> "revdatagridlibrary" and confirm that mouseUp is not being triggered  
> at all.

Good idea, said and done!

I added some lines to the "mouseup" handler in the btn "DataGrid"
answer "Mouse was clicked"
answer sDeselectOnMouseUp

and the mouseclick gets to the lib but the local variable  
"sDeselectOnMouseUp" is empty at that point so the selection will not  

But my other observation is also correct, this only happens after I  
set the custom behavior AND the stack
with the grid is a substack, honestly :-)

All is fine if that stack is a mainstack, makes no sense, but that's  
the way it is.

> Regards,
> -- 
> Trevor DeVore
> Blue Mango Learning Systems
>    -



Klaus Major
klaus at

More information about the use-livecode mailing list