DataGrid: mouseup stops working after setting dgProp["default column behavior"]: Reloaded

Trevor DeVore lists at
Wed Apr 29 10:24:06 EDT 2009

On Apr 29, 2009, at 9:33 AM, klaus at wrote:

> I posted this yesterday, but did not get an answer yet.
> If someone can give a hint or two, please do it :-)
> This is blocking our current project.

I don't think the other email ever came through.

>> Hi all, as the subject states, mouseup stopped working in my  
>> DataGrid.
>> Using the arrowkeys to navigate still works fine.
>> I added this custom behaviour via a new button, which works as  
>> exspected
>> (converts the data to Mac encoding if necessary and urldecodes the  
>> data):
>> on FillInData pData
>>   set the text of me to win2mac(urldecode(pData))
>> end fillInData
>> But after that navigating in the list with the mouse stopped  
>> working?!
>> Setting the custom behaviour to empty again does not resolve the  
>> problem,
>> I just cannot click to change the list.
>> I already quit and reopened Rev/MetaCard, still no joy. Any hints?
> I also found out that this only happens if the stack with the grid  
> is a substack!!!???
> NO problems if that stack is a mainstack.
> I already filed a bug report, but we definitivley cannot wait for  
> that one to be fixed ;-)
> <>

I read the bug report and my first question is whether or not this bug  
only happens in the standalone? Based on your bug report it appears  
that you are building a distribution and then afterwards the mouseup  
message stops working.

It sounds likes there may be a behavior bug of some sort. Have you  
tried recreating the data grid on the substack from scratch?

Another thing to do is to add some logging functions to the arrowkey  
and mouseUp messages in button "Data grid" of stack  
"revdatagridlibrary" and confirm that mouseUp is not being triggered  
at all.


Trevor DeVore
Blue Mango Learning Systems    -

More information about the use-livecode mailing list