unpacking

J. Landman Gay jacque at hyperactivesw.com
Sun Mar 2 01:44:03 EST 2008


Paul Foraker wrote:
> I'm building a stack that is a data entry app for a daily journal. Once the
> day's entries have been posted (emailed to myself), I want to store them in
> the stack. I came up with a scheme of prepending "j" to the seconds
> representing the day and using that as the name of a custom property. No
> problem storing that. When I retrieve it in a script, however, it's always
> empty.
> 
> on unpackTheData jDate -- in seconds
>   put "j" before jDate
>   put empty into tJournal
>   put the jDate of this stack into tJournal
>   -- do "put the" && jDate && "of this stack into" && tJournal -- didn't
> work

I think you do need to use the "do" statement to force evaluation. But 
the tJournal variable should be part of the "do" statement itself; Rev 
will recognize it correctly as a variable. So, something like this 
should work:

do "put the" && jDate && "of this stack into tJournal"

-- 
Jacqueline Landman Gay         |     jacque at hyperactivesw.com
HyperActive Software           |     http://www.hyperactivesw.com



More information about the use-livecode mailing list