Problem with characters/special characters in XML

runrev260805 at m-r-d.de runrev260805 at m-r-d.de
Wed Feb 20 19:01:02 EST 2008



Hi,

unfortunately i sent the message below with a wrong subject. Please excuse.


So here´s my problem, maybe someone can help.

I want to write a XML file, which should be opened in MS Excel 2003.

I have 2 xml-files, each contains the same data, if opened in Ultraedit editor under Windows.

The first one was an Excelfile, which i exported to XML with Excel. This file can be reopened 
in Excel without problems.
Here´s some sample code, how Rev reads the file (in Rev some characters are not shown like ultraedit shows them)

<Cell ss:StyleID="s21"><Data ss:Type="String">WSXGA 1680 x 1050 Pixel, Helligkeit 300cd/m², Kontrast 1000:1, Bildwinkel 160°/160° (H/V), Reaktionszeit: 5ms, Pixelabstand: 0.258mm, Signal-Eingang: Analog (VGA) u. DVI-D (HDCP), Kensington-Lock, integriertes Netzteil, TCO '03, Pixelfehlerklasse II, TÜV/GS, TÜV Ergo, 473 x 310 x 73 mm, 5.6 kg</Data></Cell>


The other one was created by me using a normal CSV file.
This one cannot be opened in Excel.

Here´s some sample code, how Rev reads that file

<Cell ss:StyleID="s21"><Data ss:Type="String">WSXGA 1680 x 1050 Pixel, Helligkeit 300cd/m², Kontrast 1000:1, Bildwinkel 160°/160° (H/V), Reaktionszeit: 5ms, Pixelabstand: 0.258mm, Signal-Eingang: Analog (VGA) u. DVI-D (HDCP), Kensington-Lock, integriertes Netzteil, TCO '03, Pixelfehlerklasse II, TÜV/GS, TÜV Ergo, 473 x 310 x 73 mm, 5.6 kg</Data></Cell> 

As you can see, my "created" file contains for example the character for degree and also some german "umlaute".

The original xml file instead shows 2 characters for each of these characters.

How can i convert my "created" file, so these characters are like the ones in the export xml-file?

I hope, i was clear enough.

Regards,

Matthias






More information about the Use-livecode mailing list