Post to https on Mac

Richard Miller wow at together.net
Wed Apr 9 19:42:22 EDT 2008


Mark,

THANK you. This seems to work perfectly. Quite a relief.

Richard


On Apr 9, 2008, at 7:04 PM, Mark Smith wrote:

> This may be an instance of bug 3639 - secure sockets don't really  
> work on OS X in my experience...
>
>
> A work around for OS X is to use curl:
>
> get shell("curl -s -d" && quote & tPostData & quote && "https:// 
> servername")
>
> You may need to change the curl incantation depending on how you've  
> assembled tPostData.
>
> Best,
>
> Mark
>
> On 9 Apr 2008, at 23:36, Richard Miller wrote:
>
>> I'm using the following and finding it's not working under OSX  
>> using Rev 2.7.4 in a standalone. Is there a known problem with  
>> this? I made sure to include the Internet library in the  
>> standalone builder. It's working fine under Windows. I'm not  
>> getting any result from the Post. It just seems to die.
>>
>> set the socketTimeoutInterval to 18000
>> set the sslCertificates to "certificatename.crt"
>> libUrlSetSSLVerification false
>> post tPostData to URL "https://servername.... "
>>
>> Thanks.
>> Richard Miller
>> _______________________________________________
>> use-revolution mailing list
>> use-revolution at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your  
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-revolution
>
> _______________________________________________
> use-revolution mailing list
> use-revolution at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your  
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution




More information about the Use-livecode mailing list