Remove subset from array
Mark Schonewille
m.schonewille at economy-x-talk.com
Fri Sep 21 06:33:56 EDT 2007
Thank you for your reply, Dick. I think that "difference" would be a
good name, although RunRev Ltd might always come up with something else.
Does anyone else have an opinion on this matter?
Best regards,
Mark Schonewille
--
Economy-x-Talk Consulting and Software Engineering
http://economy-x-talk.com
http://www.salery.biz
Quickly extract data from your HyperCard stacks with DIFfersifier.
http://differsifier.economy-x-talk.com
Op 17-sep-2007, om 22:56 heeft Dick Kriesel het volgende geschreven:
> Without a new command or function, the repeat loop is essential, I
> think.
>
> A quick check of Wikipedia suggests several candidate names:
> relativeComplement
> setTheoreticDifference
> complement
> setDifference
> difference
> setDiff
> diff
>
> See <http://en.wikipedia.org/wiki/Complement_%28set_theory%29>.
>
> Here's what I use:
>
> on set_differenceFromArrays @tArray,pArray,pCaseSensitive
> local tKey
> set the casesensitive to (pCaseSensitive is "true")
> repeat for each key tKey in pArray
> delete variable tArray[tKey]
> end repeat
> delete variable tArray[empty]
> end set_differenceFromArrays
>
> Command set_differenceFromLists uses a similar repeat loop.
>
> -- Dick
More information about the use-livecode
mailing list