Problem when filling first line of a field with a text variable

Eric Chatonet eric.chatonet at sosmartsoftware.com
Tue Jul 10 06:15:20 EDT 2007


Bonjour André,

I tried the following:

on mouseUp
   local ThisText
   -----
   put "a,b,c" into ThisText
   replace comma with cr in ThisText
   go to stack "StackTwo"
   put ThisText into line 1 of fld "ThisField"
end mouseUp

And it worked as expected.
The only thing I notice in your script is that you write:
go to StackTwo
And that's not correct syntax :-)

Le 10 juil. 07 à 11:56, André.Bisseret a écrit :

> Hi,
> After hours of unsuccessfull trials to understand where I am making  
> a mistake I make up my mind to ask for help
>
> If I summarize my script :
> I have two stacks : stackOne and stackTwo
> In the script of a button in stackOne
>
> I put a text of several lines in a variable, say, thisText
>
> then the script continues with :
>
> go to stackTwo --where I have a field “thisField”
> put thisText -- to confirm the text is in the variable
> put thisText into line 1 of fld “thisField”
>
> Invariably, I get the full text thisText in the message box – as  
> expected
> but, in fld “thisField” , unexpectedly, the first line of thisText  
> is not written in the fld thisField ; the first line of thisField  
> is empty,
> only the following lines (2, 3 etc.) are visible
>
> After a lot of hypotheses and checkings I am out of ideas
>
> Please, any assumption on what am I missing ?
> Thanks a lot in advance
>
> Best regards from Grenoble
> André

Best regards from Paris,
Eric Chatonet.
----------------------------------------------------------------
Plugins and tutorials for Revolution: http://www.sosmartsoftware.com/
Email: eric.chatonet at sosmartsoftware.com/
----------------------------------------------------------------





More information about the Use-livecode mailing list