Clipboard Anomally [BUG]?

Ken Ray kray at sonsothunder.com
Mon Nov 13 10:59:42 CST 2006


On 11/13/06 9:08 AM, "Kay C Lan" <lan.kc.macmail at gmail.com> wrote:


> All I wanted was someone, just one other person, to repeat what I've done,
> to either confirm what I'm experiencing (a bug) or determine that they don't
> experience it (then it's my set-up). If it is confirmed then I believe it
> will help solve the sporadic copy/paste anomalies that have been expressed
> here, and rather than talk about hacks and work-arounds, we can hopefully
> get Rev to copy/paste like it should.
> 
> So someone, please, with sugar on top:-)

Confirmed, Kay, on OS 10.4.7 with Rev 2.7.4 (I also tested going back to
MetaCard 2.6.6, and it's the same thing, so it's systemic to the MC/Rev
engine).

I also noted that it didn't matter if Rev was already open or not. That is,
I had thought that perhaps Rev would "initialize the scrap" when it opened
and recognize any text that was there, so I quit Rev and relaunched and then
tried to paste or examine the clipboard and it was still empty (even though
I could switch to other apps and paste the text on the clipboard with
freedom).

One oddity I noticed was that if I switched back to the open TextEdit
document, highlighted the text and copied it *again*, then switched back to
Rev, it would recognize it.

I even tried a workaround with AppleScript to get the data on the clipboard
and still no dice.

Bug confirmed!

Ken Ray
Sons of Thunder Software, Inc.
Web site: http://www.sonsothunder.com/
Email: kray at sonsothunder.com




More information about the use-livecode mailing list