Unix scripting help

Chris Sheffield revlist at cableone.net
Thu Sep 29 10:50:59 EDT 2005


I hope I'm not totally off topic here.

I've got an installer in Rev that has to start a process under OS X  
using the shell function.  I'm able to get the process to start just  
fine using a command line script.  But the problem I'm having is this  
particular process does not return any value when started, and the  
shell command is not exiting because of this (at least that's what I  
assume is happening).  So my script just kind of hangs at that  
point.  The process I'm starting is the Valentina database server.

So what I'm looking for is a way to run my script, which starts the  
process, but include in my script something that says, "Okay, I'm  
finished now", and will allow my handler to go on at that point.   
This is the current script I'm running with the shell function:

#!/bin/sh
pw=[PasswordHere]  -- this is obtained earlier with an authentication  
dialog
echo $pw | sudo -S /Library/RNSEServer/RNSEServer &
exit


Now, if I run these lines one at a time from a Terminal window  
everything works great.  But if I run the script all at once, whether  
from Revolution or from a Unix script file, it hangs, almost as if  
the exit command isn't executing.  So is there something I can use in  
place of 'exit' that will cause my script to finish?  Or is there  
same way to cause the shell function not to wait like it does by  
default?  I was previously using "open process" instead of shell, and  
that worked except that it would launch the process as the user who  
was logged into the computer rather than as the root user, and I need  
it to run as root.

Any help would be appreciated.

Thanks,
Chris


------------------------------------------
Chris Sheffield
Read Naturally
The Fluency Company
http://www.readnaturally.com
------------------------------------------





More information about the Use-livecode mailing list