Problems with streaming audio

Howard Bornstein howard.bornstein at gmail.com
Mon Sep 12 18:26:32 EDT 2005


On 9/12/05, Mark Talluto <userev at canelasoftware.com> wrote:
> 
> On Sep 12, 2005, at 11:31 AM, Trevor DeVore wrote:
> 
> > Mark,
> >
> > Have you tried controlling streaming movies by setting playRate?
> > This has worked reliably in my tests and it fixed a problem that
> > one person had been having for 6 months.  Just don't use start/stop
> > player.
> 
> Trevor,
> 
> I just tested using playRate and it works well.  I could not
> replicate the problems with players that are created and set to play
> automatically.  Thanks for the tip!  I will update Bugzilla with this
> info.
> 
> If you have a player with the controller visible, and the player is
> not started with the playRate command, then the problem returns.  I
> supposed a frontscript could catch the clicking of the mouseUp on the
> controller's play button.  I tied putting a mouseUp in the player
> itself.  If you click on the movie portion, it works.  If you click
> on the player button in the controller, it gives an error of:  5401
> Bad State.
> 
> This is a viable workaround for now though.  Thanks!
> 

Unfortunately, this is not working for me. When I tested on Windows
2000 with Rev 2.6, the Start Player command did not work, even though
your tests showed it works under Windows. I get the same response as
on the Mac--the player tries to connect and never does. Then, when I
try using set the playRate to 1, Rev completely hangs and I have to
force-quit. This was completely repeatable.

Why would I be getting such different results as you?

-- 
Regards,

Howard Bornstein
-----------------------
www.designeq.com



More information about the Use-livecode mailing list