Corrupt .rev file?

Richard Gaskin ambassador at fourthworld.com
Sat Nov 12 10:19:27 CST 2005


Erin D. Smale wrote:
> Hello all,
> 
> I'm experiencing some odd behaviour with my stack. I was working on an
> application last night when I tried to select the Standalone Application
> Settings. When I clicked on that menu option, nothing happened. After some
> checking, I realised that none of the menus in the Revolution main toolbar were
> working. Dutifully, I shut everything down and restarted.
> 
> When I opened the stack again, I found that not only were the menus not
> functioning, but I couldn't use the right-click options on an object, nor would
> the commands accessed from the Propery Inspector work. If I select an object on
> the stack and use the CTRL+E command, the script editor comes up, but it's
> blank.
> 
> Oddly, if I run the stack in Dreamcard viewer, it works just fine. If I open
> Revolution and work on another stack, everything works as expected.
> 
> So it would seem that there's something wrong with just one .rev file, although
> I can't figure out what. Is it possible for a .rev file to become corrupted?


Corruption of a stack file is possible, but extremely rare.  I won't 
even bother getting into the details again -- you can search the 
archives for "corruption". In 8 years with the product I've only even 
hear about two cases of true file corruption.

Slightly more frequent (perhaps as many as a dozen cases over 8 years) 
is the corruption of data in an image object.  In such cases merely 
replacing the image object will bring all behaviors back to normal.

Fortunately it seems neither of these are related to your issue, since 
you note that the same stack file works great in Dreamcard. If the stack 
is fine, the stack is fine.

Your description above says that the stack even worked fine in Rev until 
you selected the "Standalone Application Settings" item.  So it seems 
the stack is fine there too, the problem being something with the 
Standalone Applications Settings stack or mode.

I don't build my standalones in Rev so I can't offer much guidance 
there, but at least I can offer 99.999% assurances that, based on your 
description, your stack file is fine and the only problem is the 
behavior of Rev's Standalone Application Settings.

--
  Richard Gaskin
  Managing Editor, revJournal
  _______________________________________________________
  Rev tips, tutorials and more: http://www.revJournal.com



More information about the use-livecode mailing list