Corrupt .rev file?

Erin D. Smale esmale at welshpiper.com
Sat Nov 12 10:01:13 CST 2005


Hello all,

I'm experiencing some odd behaviour with my stack. I was working on an
application last night when I tried to select the Standalone Application
Settings. When I clicked on that menu option, nothing happened. After some
checking, I realised that none of the menus in the Revolution main toolbar were
working. Dutifully, I shut everything down and restarted.

When I opened the stack again, I found that not only were the menus not
functioning, but I couldn't use the right-click options on an object, nor would
the commands accessed from the Propery Inspector work. If I select an object on
the stack and use the CTRL+E command, the script editor comes up, but it's
blank.

Oddly, if I run the stack in Dreamcard viewer, it works just fine. If I open
Revolution and work on another stack, everything works as expected.

So it would seem that there's something wrong with just one .rev file, although
I can't figure out what. Is it possible for a .rev file to become corrupted? If
so, what does one do to address it, and what steps can be taken to avoid it?

As a side note, if the file is lost or unusable, it's not earth-shattering. I
can replicate the code easily enough--I really want to avoid laying out the GUI
again, though.

Any advice, tips, suggestions appreciated. Thanks,

-Erin

Check out The Chimera RPG:
http://www.welshpiper.com/



More information about the use-livecode mailing list