Buggy debugger?

Timothy Miller gandalf at doctorTimothyMiller.com
Mon Jul 11 21:34:09 EDT 2005


I still can't figure out whether I'm doing something wrong when I try 
to use the debugger, or if there is something wrong with the 
debugger. Eric suggested there's a flaw in the debugger, but his 
comment was ambiguous. I'm on version 2.5.1 in OS X. If there is a 
problem with the debugger, I'd like to know if it's been fixed in 
version 2.6.

I should mention that I've used hyperCard's debugger many times over 
the years, in a variety of ways, with no problems at all. "Step into" 
and "step over" and all of that are all familiar. So are the message 
watcher and the variable watcher. Rev's debugger looks quite similar, 
but I can't get it to work.

I described the details in a previous message, but I didn't get a 
reply. That's probably because I should ask only one question per 
thread. Anyway, the newbie thread pumped up my courage, so I'm asking 
again.

The details of my debugger frustration, previously described:

>It works fine on, for example, a simple mouseUp script in a simple 
>button. However, if the button sends a message to a handler in a 
>stack script (for instance), which then sends another message to 
>another handler, nested or not, the debugger won't follow along. 
>"Script debug mode" is definitely turned on. Step Into, etc., are 
>absent and/or dimmed out, typically. Sometimes, I can see the script 
>window open, several windows back, but I can't get to it until the 
>script is done executing. I've tried setting multiple breakpoints in 
>each handler, tried setting breakpoints by script. The script rolls 
>right past them.

Just a brief reply will do. Drop me a hint and I can probably figure 
out the rest.

Thanks in advance,


Tim








More information about the Use-livecode mailing list