How To Debug "A problem opening that stack"?

Rob Cozens rcozens at pon.net
Sat Dec 3 10:41:32 CST 2005


Morning All,

I alluded to this a couple of days ago but saw no response; so once again...

At least half of the Revolution stacks I created on Mac platforms 
before switching to Windows XP TPC Edition as my development platform 
will not open in Rev 2.6.1 for Windows.

Occasionally I get an answer dialog with the message "restructure 
license?" and _no_ response buttons.  Usually I get an answer dialog 
with the message "There was a problem opening that stack".  Sometimes 
this dialog includes an "OK" response button; sometimes it doesn't.

I have tried opening some of these stacks with messages suppressed, 
and the error persists; so it would seem the problem is stack 
structure, not my scripts.

Question 1: Has Revolution stack file format changed between v2.1+ 
and v2.6+?  If so, where is this documented and where is a format converter?

Question 2: How do I debug the problem short of:

	* deleting each control in a stack and seeing if it will then open, or

	* control-by-control comparison of a stack that opens and one that doesn't

Question 3: Could this be happening because my Studio license is 
Windows-specific and the stacks were last saved on Mac OS X?  If so, 
what does this imply for developers providing stacks to other 
developers licensed for a different platform?

Rob Cozens CCW
Serendipity Software Company

"And I, which was two fooles, do so grow three;
  Who are a little wise, the best fooles bee."

  from "The Triple Foole" by John Donne (1572-1631)




More information about the use-livecode mailing list