Can't read text from file on OS 9

Andre Garzia soapdog at
Wed Sep 22 15:36:11 EDT 2004

On Sep 22, 2004, at 4:23 PM, Trevor DeVore wrote:

> I have a weird problem here.  I built a standalone for OS 9 using 2.5. 
>  I'm testing under Classic but a client is testing on a machine 
> running OS 9.
> In the code I use put URL ("file:"&pPath) into tMyVar to get text from 
> a file.  The path is one retrieved from the answer file command.  On 
> OS X and Windows the text is retrieved without a problem.  Not so on 
> OS 9.  I just get empty.  I also tried open file, read from file and 
> close file but that doesn't work either.  No errors are reported, just 
> not data from the file.
> Can anyone else confirm whether this is happening on their end?


I had similar problem here, it was a bug that happened only running the 
stack under classic emulation, on REAL MacOS 9.x it worked fine... so 
it was labeled low priority in bugzilla. (or might even be solved by 
now). Try setting your startup disk to the MacOS 9.x system and reboot, 
run your app to see if bug persists. To not trust classic emulation, 
try real os 9.x


Andre Alves Garzia ð 2004 ð BRAZIL

More information about the use-livecode mailing list