update on pamela crisis

pkc pkc at mac.com
Sun Aug 1 15:44:35 EDT 2004


Hello all, a little more to report, and responses:

In my last message, I wrote:
>
>My program of fixes (now under weigh) is:
>
>1) Rename the current file on the FTP server with a "zip" suffix.
>Have unwitting subjects download it and see what happens.Transfer
>said renamed fake zip via disk and try to open. Probably won't work,
>but would tell a lot if one or both did.


Tried this.  As predicted, a failure.

>2) Actually compress the file with Stuffit, replace the old file on
>the server, proceed as above.Transfer said genuine zip via disk and
>try to open.  I figure, slightly better chance of success?

Tried this. Contrary to predictions, a failure.

>3) Reinstall Revolution, re-download Win32, rebuild everything, zip,
>proceed as above.

Had hopes for this one. Just got the report:  Exact same "0,0" error.

>4) Transfer the stack file to some Windows machine somewhere running
>Revolution and build the thing.  Has to succeed, no?  But we would
>learn nothing.

Marian was kind enough to do this. Her comments are below. This was 
also a failure.

>5) Flunk the 80 percent of the students in the course who are using
>Windows, on the grounds that their work is incomplete.  Attractive in
>its way.

Imminent.


Ambassador wrote:
>
>Hmmmm....Windows has no such thing as a bundle.  On Win, Mac bundles
>appears as folders.   But since Win executables are a single file, they
>should not look like a folder.


This is what is so mind boggling about this. When I moved the .exe 
file to my PC to see what the students were talking about, there was 
a bundle --a folder, a .ds store file, a GUI file, and another file I 
expect is the executables.  But the properties windows identifies the 
latter two as applications.  When I transferred this via CDR, I got 
one icon, but showed an apparent GUI window, and gave the "0,0" error 
when I tried to open it. Properties window says it is an application.

>  Maybe you're copying
>the OS X builds?
>

If so, I have no idea how to avoid it. In the standalone builder, 
nothing is checked but Windows and nothing comes out but an .exe 
file. I am not building the OS X application simultaneously.


Troy wrote:
>
>Keep in mind, this is NOT an insurmountable issue. Lots of us make
>Windows builds from our Macs every day, with no special tricks or
>unspoken know-how. We'll figure it out.

I understand.  I've been doing this exact same thing --building on 
mac, distributing to windows-- with Revolution for nearly five years 
now. Never had a problem like this.  Have been quite an advocate for 
getting Revolution more involved in our teaching. Now the whole 
school knows the course has ground to a halt for Windows-using 
students.  I have never ever had these problems and have been able to 
solve all Revolution problems up to now. This one appears 
inexplicable, let alone solvable.

Marian wrote:
>
>Downloaded Pam's stack (and the ZIP file version of Rev 2.5 b1) on my
>Mac. Transferred Pam's file over to PC over my wireless network but the
>file will not open in Rev 2.5b1 on my PC--says file is corrupted.
>
>Tried changing the name to something more DOS-friendly (PamStack.rev). 
>No luck.
>
>Changed name to PamStack.rev on Mac, zipped it using drop zip, still
>says file is corrupted when I try to open it using the PC version of
>2.5b1.
>
>Same problem if I try to open the file using Rev 2.1.2 on PC.
>

...

>Opens fine in 2.5b1 on the Mac. Doesn't open in either 2.12 or
>2.5b1 on PC, whether it was sent there directly or having been zipped
>first.


Troy wrote:

>Whoa.
>
>No newsflash, but something not right there.
>
>Rev says the file is "corrupted"? What if "lock messages" is turned on
>before opening? Any weird Mac specific things going on in openStack or
>pre-open card handlers?
>
>Maybe, each substack could be saved as an individual file, transferred
>and opened... to determine the real culprit.
>
>Maybe somebody like Richard, Chipp, or Ken could have some better ideas.

I would probably not recognize "weird Mac specific things" happening 
in my scripts. So far as I know, there is nothing weird in the 
scripts at all.

Marian wrote:
>
>I took the .rev file I initially downloaded from Pam's iDisk using my
>Mac and opened it in Rev 2.1.2 Mac version.  No prob.  Created a Mac
>and a Windows standalone using Rev 2.1.2.   Mac standalone works fine.
>
>Sent Windows standalone over to PC directly over my wireless network. 
>Attempt to run it gives 0,0 error message reported by Pam.
>Zipped Windows standalone and sent it to PC also over my wireless
>network.  Unzipped on PC. Attempt to run it gives same 0,0 error:  
>"<filename>, error was 0,0"
>
>Pam, what about Troy's suggestions?


You mean about weird scripting?  Absolutely nothing comes to mind. 
But why take my word for it?

You can all join in the mystery stack sweepstakes.

I have reinstalled Rev 2.2.1 on my G5.  The program will now properly 
download the Win32 engine (good news), and it has done that. I made a 
fresh directory and built the Windows standalone into it. I put it 
online for my students to FTP. They did. It is a bust.  Error 0,0.

I saved both the stack file and the Windows build directly into my 
iDisk (maybe there is some spooky formatting on hard disk that is 
messing up the file?):  pkc.  No password.  Take a look for yourself. 
It sounds like the solver of this scientific mystery should get a 
Nobel prize.


More information about the Use-livecode mailing list