Question about Linux Builder Requirements

A.C.T. albrecht at act-net.com
Sat Apr 3 13:25:31 EST 2004


Hi, John,

thanks for your list, perhaps I can help - without having a "running 
Revolution application" on Linux yet - getting some issues solved:

> - Some very strange window behavior...things that work on Mac and Windows
> don't work on Linux (some custom 'drag' handlers did not work, and
> decorations had a trick to it).

That may be related to Windows and MacOS using a different windowing 
system than X, which is "client-server". I guess these issues would have 
to be solved on Revolution's site, but I can imagine it could be quite 
tricky.

> - You need to watch your file names (Linux does not like 'Spaces'), but it
> seems to be OK with folders. 

Unix (Linux) "loves" Spaces, but they have to be backslash-escaped if 
you use shell tools. I don't know how Revolution accesses files, if it 
uses system calls like "fopen" etc, spaces definately would be no 
problem. Perhaps there is a bug inside the filehandling in Revolution 
leading to a wrong escaping on Linux but the correct escaping on Mac and 
Windows. Information about how file access is being done inside the 
engine would help here.

> - The 'defaultFolder' is not what you expect, so you just parse the current
> stack name to get the current directory.

I would expect the working directory to be the "Default Folder". WD 
depends on what is set as WD inside the shell session you are in. I can 
only guess here (I currently do not have a working Revolution app under 
Linux), but you could try doing a "cd your-default-directory" during 
startup of your stack, I would expect this to lead to the needed behaviour.

> - Sockets work fine except for broadcasting (not related to Revolution).

Broadcasting (always) depends on the network settings/network hardware 
setup. Broadcast has to be handled with care as it can lead to routing 
problems. One could do a tracking about networking setup being done by 
Revolution - or such information could be given by RunRev.

> - No icon support for your stand-alone other than what Gnome or KDE
> provides.

This has to be resolved by RunRev. Windowing systems like Gnome and KDE 
do offer "personal" icons, perhaps there is a bug in the app builder?

> - Fonts are very minimal, and there doesn't seem to be support for TrueType.

This surely isn't a problem of Revolution/RunRev: Support for TrueType 
is offered through various libraries, but isn't a "native feature" of 
most windowing systems. It is possible that calls for font rendering 
inside the Revolution engine is not up-to-date but I would not call this 
a bug. In ancient times one always had to "render" the font required to 
native format ...

> It seems stable though  ;-)

No doubt about that. I wish I could actually create RUNNING applications ;-)

Mit freundlichen Grüßen,
Marc Albrecht
A.C.T. / Level-2
Glinder Str. 2
27432 Ebersdorf
Deutschland
Tel. (+49) (0)4765-830060
Fax. (+49) (0)4765-830064


More information about the Use-livecode mailing list