Rogue visual effect sends rev awol

DVGlasgow at DVGlasgow at
Sun May 25 10:29:01 EDT 2003

I have an assessment card that shows and hides lots of objects with visual 
effect dissolve (not QT).  When the assessment is complete, I have a continue 
button with :

on mouseUp
  visual effect reveal left
go card "results"
end mouseUp

The results card arrives with a *dissolve*, but then sits with nothing 
happenning for maybe two minutes.  During this time nothing in the Rev environment 
is doable, including cmd period.  I can swtch between finder and rev though.   

After AWOL time I get a reveal left effect to the same card, then frantic 
clicks catching up with whatever I tried during AWOL.  I assume I have stacked up 
a spare dissolve that I don't use  - (although I thought they were used last 
in first out, so to speak, no?.)

I can't for the life of me find the extra visual effect, and I have tried to 
clear it using: 

    repeat until the pendingMessages is empty
      cancel item 1 of line 1 of the pendingMessages
    end repeat

This was just a guess, assuming that 'stacked' visual effects are pending 
messages, and doesn't do the trick.

The opencard handler on the results card does have a fair bit of scripting on 
it, but this weird pause only happens if I come from the assessment card 
*having done the assessment*.  If I just navigate to the assessment card and then 
hit the continue button, all the opencard scripts execute in a fraction of a 
second and everything is responsive.

Any suggestions?  Is there a specific clear pending effects command? Or maybe 
I am barking up the wrong tree.  Any help appreciated.

Best wishes,

David Glasgow
Home/ forensic assessments --> <A HREF="">
DVGlasgow </A>
Courses --> <A HREF="">i-Psych</A>

More information about the use-livecode mailing list