fast forward QT movie crash

DVGlasgow at aol.com DVGlasgow at aol.com
Wed May 7 11:54:01 EDT 2003


Hello, once again, I am leaning on the list.....

Still struggling with my video training stack for my Rev standalone product.

Using 1.1.1 on 9.1

Simple is best.  A 1 card stack with a group of buttons called "play 
tutorial"  which is used as an index and to start the various movies.  
Mouseup on each button just names the movie, sets the volume (becuse I was a 
bit erratic volumewise when I was recording) and sends playit which is caught 
by the card.

On the card I have:


on preOpenCard
  hide player "viewer"
  show group "play tutorial" with visual effect dissolve
end preOpenCard

on playit
  global gvid,gvol
  hide group "play tutorial" with visual effect dissolve
  wait 20 ticks
  set the filename of player "viewer" to "video/" & gvid
  set the currenttime of player viewer to 0
  set the playloudness of player "viewer" to gvol
  show player "viewer" with visual effect dissolve
  wait 20 ticks
  play player "viewer"
end playit

on playstopped
  hide player "viewer" with visual effect dissolve
  set the filename of player "viewer" to empty
  show group "play tutorial" with visual effect dissolve
end playstopped

Now, everything works fine.  EXCEPT if a user uses the fast forward button on 
the QT controler to go to the end of the movie (as opposed to dragging the 
blob or allowing the movie to play) the playstopped handler runs to show 
group play tutorial, then the whole thing seems to get stuck in a slowly 
flickering visual effect.  The stack refuses to respond to any clicks, and 
unless the debugger is open, neither will rev.  If the debugger is open, I 
can edit scripts, access the application overview, - all sorts, but still not 
use the stack and also not quit rev.  Happens everytime, and once a force 
quit took the system with it.

I tried to set dotuseqteffects to true, with no luck.

I am going to mess with the effects to see if it really is a runaway effect.  
Since I may well be barking up the wrong tree, any ideas?


..........................OK time has passed, and I changed all the dissolves 
to wipes.  The playstopped handler does run, and no flickering this time, but 
the hang still happens.  The wipe also stays 'live' in that if I switch 
applications, the wipe applies to all windows appearing and disappearing in 
front of Rev!

Best wishes,

David Glasgow
Home/ forensic assessments --> <A HREF="http://members.aol.com/dvglasgow/">
DVGlasgow </A>
Courses --> <A HREF="http://www.i-Psych.co.uk">i-Psych</A>



More information about the Use-livecode mailing list