GET Request from Revolution Fails

Brian Yennie briany at qldlearning.com
Sat Dec 27 00:45:55 EST 2003


You're correct- Rev doesn't do https, as it requires SSL support.
If you use curl, you don't have to include the POST args as a  
command-line argument if you are worried about it showing up in a  
process listing, etc. You can pipe the data- check out the man page for  
curl, and look at the -d option description.

I'm not sure how using curl would put anything different in your server  
logs than a Rev request...?

HTH
Brian

> OK more info on this one:
>
> We suspect it is because Revolution is not able to accept an https  
> URL... it return "Invalid URL"  a search on the lists doesn't turn up  
> much....
>
> Hope there is a work around and we are missing something simple...
>
> ## where we are trying to get the returned web page from verisign
>
> put URL  
> "https://payflowlink.verisign.com/ 
> payflowlink.cfm?LOGIN=himalayanacademy&PARTNER=VeriSign&AMOUNT=5&TYPE=S 
> &ORDERFORM=False&SHOWCONFIRM=False&CARDNUM=4111111111111111&EXPDATE=050 
> 7&DESCRIPTION=Order+description+here&NAME=Billing+name+here&ADDRESS=Bil 
> ling+address+here&CITY=Billing+city+here&STATE=HI&ZIP=96746&COUNTRY=Bil 
> ling+country+here&PHONE=8088223012&FAX=8088223012&USER1=&METHOD=CC"  
> into temp
>
> put the result
> -------
>
> changing this to :
>
> GET URL temp
>
> also doesn't work.
>
> we get the same error. "it" is empty as well.
>
> Now if I paste the same url into a browser it works perfectly.  
> Strange. Any ideas? It almost looks as if Rev can't to https  
> connections??
>
> What I really want to do is use POST as in the following (but that  
> doesn't work either):
>
>   POST  
> "LOGIN=himalayanacademy&PARTNER=VeriSign&AMOUNT=5&TYPE=S&ORDERFORM=Fals 
> e&SHOWCONFIRM=False&CARDNUM=4111111111111111&EXPDATE=0507&DESCRIPTION=O 
> rder+description+here&NAME=Billing+name+here&ADDRESS=Billing+address+he 
> re&CITY=Billing+city+here&STATE=HI&ZIP=96746&COUNTRY=Billing+country+he 
> re&PHONE=8088223012&FAX=8088223012&USER1=&METHOD=CC" to URL  
> "https://payflowlink.verisign.com/payflowlink.cfm"
>
> We could use the onboard "curl" shell command but the credit card info  
> is going to end up in the server logs... not ideal.
>
> Thanks!
>
> On Dec 26, 2003, at 4:18 PM, Sannyasin Sivakatirswami wrote:
>
>> If we set up a GET request URL string and put it in a browser, it  
>> works. This is a typical credit card transaction with VeriSign,  
>> Payflow Link. We want to be able to set this  up in Revolution, but a  
>> simple GET url with the same string as used in the browser fails. I  
>> can create a xTalk CGI with the exact same URL string and  that works  
>> either with POST or GET. But if I try to use GET from Revolution to a  
>> VeriSign CGI it fails.  We suspect VeriSign is wanted some special  
>> headers? If so, what might it be? Their documentation on creating the  
>> web back end for this was pretty clear and we followed it, but it  
>> still doesn't work from Revolution.
>>
>> Meanwhile we will test by returning the globals from  GET sent from a  
>> browser, to our own CGI,  and then make our own httpheaders going out  
>> from the Revolution app, to match the browser request, but this still  
>> is not going to clue  us into exactly what is causing the GET to  
>> VeriSign to fail.
>>
>> Once we get the script to work at home, hopefully this will be  
>> transferable to the web site to run as a faceless back end CGI script  
>> on the web server where and old version of MC Linux engine is  
>> installed (we are still unable to install a new Linux version of the  
>> Revolution engine because it wants those libraries that are not  
>> installed.)
>>
>> The goal is a full-fledged back end xTalk CGI solution to a store  
>> front with automatic run-time, credit card verification, run and  
>> deposit, we are very, very close, but still fumbling in the dark  
>> here... help!
>>
>> Sannyasin Sivakatirswami
>> Himalayan Academy Publications
>> at Kauai's Hindu Monastery
>> katir at hindu.org
>>
>> www.HimalayanAcademy.com,
>> www.HinduismToday.com
>> www.Gurudeva.org
>> www.Hindu.org
>>
>> _______________________________________________
>> use-revolution mailing list
>> use-revolution at lists.runrev.com
>> http://lists.runrev.com/mailman/listinfo/use-revolution
>>
>
> _______________________________________________
> use-revolution mailing list
> use-revolution at lists.runrev.com
> http://lists.runrev.com/mailman/listinfo/use-revolution
>
>



More information about the Use-livecode mailing list