Weird Output from revPrintField

Gardner, Joseph A joe.gardner at nwa.com
Wed Oct 2 02:08:01 CDT 2002


Hello folks. I've searched my own archives of the list for a mention of this problem, but haven't found anything. I have a simple button with the following script:

  on mouseUp
    revPrintField ("field" && quote & "FileContents" & quote)
  end mouseUp

The contents of the field "FileContents" is a single line: This is text file 1.

When this button is pressed the printer (a networked HP LaserJet 4050) spits out the following:

This is text






file 1.

Anyone have any idea why this is happening? It gets even worse with longer field content. A 10-line field can print 7 or 8 pages! The text as printed is normal size. I'm running this from a Dell GX110 with Windows2000. I've tried all the other command iterations in the Rev documentation including all the revPrintText possibilities. They all produce the same spaced-out output.

Appreciate any suggestions and/or comments. And yes, I've also tried inserting the old revShowPrintDialog command in front of the revPrintField command, but that never does anything even with both options set to true.

joe.



More information about the use-livecode mailing list