The Last Three Tutorials--Mac Classic 1.1.1

Rob Cozens rcozens at
Mon Mar 25 12:49:01 EST 2002

General note:  I'm having problems knowing what tool I should see 
when.  It seems, if the cursor is over a stack or palette it's the 
browse tool; but when the cursor moves over the menubar or any 
Tutorial stacks it changes to the pointer.

Geometry Manager:

A. Will this work correctly with a stack that has been scripted for 
the Animation Tutorial?  I had problems after clicking on "Reset" 
after installing the animation; so I replaced the "Show Me" script 
referencing the animation with the one from the Getting Started 

B. The first time through I changed positioning settings instead of 
scaling settings or vice versa and got thoroughly confused.  Is there 
a way to tell the Geometry Manager "forget everything I've done so 
far" and start over?

C. The second time through I was much more careful to pay attention 
to what I was changing where, and I had no problems.

D. Suggestion: The tutorial instructs one to set the field in the 
same manner as the buttons (ie fixed distance from the bottom).  I 
found centering the field to the center of the card produced (IMFO) a 
better effect.

5. Profile Manager:

A. Can the Profile Manager & the Geometry Manager work together? 
When I select profile "LargeFont" the buttons no longer change 
position when I resize the window.  If I revert to "Master", the 
Geometry Manager settings work again.  Would the preferred method be 
to set up the profiles before working with the Geometry Manager?  And 
is it necessary to apply the Geometry Manager once to each object for 
each profile?

6. Independent Study:

A. I believe the issue of the image not appearing has already been 
mentioned.  I will add that after clicking at what I presume to be 
the picture image location and selecting one of the employee jpgs, I 
am returned to the database in the pointer tool instead of the browse 
tool with no picture visible.  Likewise, when I enter the employeedb 
stack after clicking on the "Open Example" button on card 13 of this 
tutorial, I am in the pointer tool and must click on the tool palette 
before I can click on a button.  Has this something to do with being 
in the development environment?

B. After creating an employee db I clicked on the left corner close 
box.  I was not shown a "Save" dialog.

C. When selecting "Close" from the menubar, I was shown a "Save" 
dialog; however the employee db tutorial did not list either of my 
.edb files when I tried to open an existing db.  I found the dbs I 
created were file type "RSTK" instead of "EDB_" I tried changing the 
file type to "EDB_" using ResEdit; but the main stack still didn't 
recognize my .edb files.

D. Clicking on the "Open Example" button on card 13 of this tutorial 
a second or subsequent time without quitting Revolution doesn't seem 
to open the stack correctly.

E. Importing data into a new db gave me a blank record "Card ID 1031" 
in addition to Fernando, Karen, Lavonne, & Joe...all with no 
pictures.  Export data worked fine...although I deleted "Card ID 
1031" before testing it.  I presume one could modify the 
import/export handlers to (optionally?) include the name or id of the 
employee's image, and that import could place the image on the card.

Having completed all six tutorials, I am:

1.  Left with some uncertainty as to how the various managers can be 
applied in concert; but

2.  More impressed than ever by what the RunRev team, albeit with a 
strong underpinning via MetaCard, has accomplished.

Rob Cozens
CCW, Serendipity Software Company

"And I, which was two fooles, do so grow three;
Who are a little wise, the best fooles bee."

from "The Triple Foole" by John Donne (1572-1631)

More information about the use-livecode mailing list