system bloat problem with rev on 68K mac

Martin Baxter martin at
Sun Mar 17 11:11:00 EST 2002

I have an old quadra 630 at home and I thought it would be useful to have
revolution installed on it mainly so I could swot-up on the transcript
dictionary when I'm at home and thinking about possible ideas.

When I tried to run revolution on it though I found that the system's
memory allocation just grows and grows until it has used up all the
available ram, at which point of course everything chokes.
The system is 7.6.1 and usually uses 5-6 megs of ram out of a total of 40
megs (36physical and 4 virtual).
The system consumes about 24 megs in the process of loading revolution
Watching the "about this computer" window while it loads and then once I'd
begun to work in the program, it looks like the system never releases any
memory, most every time revolution does something the system just grabs
another chunk until eventually it has grown too big for the available space
and everything comes grinding to a halt.

This is the latest beta1.1.1 Classic that I downloaded on saturday, I
haven't tried this with any previous versions so I don't know if it's
something new or not. It doesn't seem like this ought to be happening

Has anyone come across this before? Is it perhaps some conflict peculiar to
my system?

martin baxter

martin baxter Cambridge UK

More information about the use-livecode mailing list