Problems with patterns on Mac

JohnRule at JohnRule at
Sun Mar 3 10:03:01 EST 2002

At 7:19 PM -0800 2/28/2002, JohnRule at wrote:
>>If I then transfer this stack to a Macintosh, the buttons
>>represent the pattern as if the pattern were the size of
>>the stack (or screen). In other words, the pattern is
>>reflected differently in every button on the Mac (the
>>pattern is not redrawn at a 0,0, coordinate for each button).

>Do you see this same result if you set the pattern property on the Mac (in
>other words, not transferring the stack)? Or is it only when transferring
>stacks that have had their pattern set on Windows?

Revolution Rev 1.1.1 B1
Windows 98SE
Mac OS 8.6, 9.1

Try this:

Create a pattern on a Windows machine (mine are 80 x 80 cells created in 
PhotoImpact), or any image file that would fit in a typical button will do.

Create a new main stack, and create three new buttons.

Import the pattern/image into Revolution.

Assign the 'image' as a pattern to the three buttons of the same size, 
stacked on top of one another.

Move the buttons around the screen (in edit mode)...the patterns remain the 

Now save, and export to a Mac.

(On the Mac)
Problem number 1...the images are gone, you have to change the button type to 
'Rectangle' or turn the border off for the pattern to show up.

Problem number 2...on my computer, I can actually move the buttons around the 
screen (in edit mode) and the pattern will if the pattern is 
drawn in the background, and I am just seeing a portion of the pattern. It 
doesn't do this on my PC.

If I assign the pattern as an icon, it draws properly, but I lose the very 
important capability of having the button name appear in the middle of the 
button. Of course, I can import button images that have the text embedded 
into the image, but it increases my application by megabytes, and it is 
extremely tedious to maintain a database of on/off images for every single 
button (which could be thousands).

>Do you see this same result if you set the pattern property on the Mac (in
>other words, not transferring the stack)? 

It makes no difference if I create this from scratch on the 
exhibits this behavior no matter what I do.

Please see if you can fix this...

Thank You,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the use-livecode mailing list