Dar Scott dsc at
Wed Jul 10 15:03:01 EDT 2002

On Wednesday, July 10, 2002, at 01:28 PM, Larry Forsgren wrote: 
> Unfortunately not. The mail server is on Unix (and I have tried a few
> which give the same result) and the client is on Windows XP. I can open
> the socket and read the welcome from the mail server but not access
> the socket with any command after that. It times out and nothing 
> else happens.
> When I check the socket it is reported as still open.

By openSockets()?  By netstat?
> >Any chance your mailserver is the same computer?  And on Windows?
> >If so, I may have run into something similar.

Is the mail server on the same LAN?  I have seen the same symptoms 
on an XP client to LAN server that I have with W2K to same 
computer.  I think the problem is related to a fast response.  How 
fast is your XP compared to your net?

At the same open where I can't write in the problem I'm seeding, I 
also don't get an open callback.  The socketID is in openSockets 
and the other end thinks it is open and my realtime tcp watcher 
thinks it is open.  Callback failure is so much easier than 
checking write, that I use it as the primary indicator for this 

On my XP I found that my stack would work just fine for a 
connection out on the Internet but would fail in this manner on my 
LAN.  Is that something you can check?

OK.  This next one is weird, but it won't take long.  This happens 
on my Windows 2000 computers.  Each time before you click the 
button to run your test, grab the title bar of the window with the 
mouse and move the window a little bit.  Then click the button to 
run the test.  If that makes it work, then it is probably the same 
problem.  If not, we don't know.

Of course, it may be something else.  Put in your diagnostics and 
let us know what the results are like.

Dar Scott

More information about the use-livecode mailing list