It's a list! It's an array! No, it's...

Dar Scott dsc at swcp.com
Thu Dec 5 15:05:10 CST 2002


Here is something I'm tinker with.

I am packing values into a single value in a way that is not a list and 
is not an array.  One can use it for order.  Access is fast, but 
increases with distance from the front.  You access the first or the nth 
or the last.  Indefinite nesting is allowed.  They can be concatenated 
and quickly split up even into singletons.  Values can be any string and 
I'm about to add arrays and numbers when I get to it.  They don't save 
space, I don't think.  They can be typed arbitrarily.  For text data, 
these can often be read by human debuggers.

What is a good name for this?

Group?
List?
Poke?
Bunch?
Sequence?
Table?
darList?
Bundle?
Gob?
Box?
Stack?
Book?
Mr. Squishy?
Pile?
Leest?
Can?
Container?
Pallet?
Chain?
Beads?
ntuples?
Blocks?
Boxcars?
Train?
Caravan?
Envelopes?
ThingsYouCanPutValuesIntoInOrder
G?
nt?
file?
queue?
bag?

Dar Scott






More information about the use-livecode mailing list