Windows 10 app launch error - 'failed to load External: tsNet'

Martin Koob mkoob at
Mon Jan 11 17:28:07 EST 2021


I have a GLX Framework based application that I am trying to create an installer for Windows 10 using Inno Setup as explained here.

This is the second Windows installer I am making.  The first time I made an installer for my first version of this app on Windows ultimately worked (after a bit of trial and error) and now I am using the same basic script settings to make the new installer for an update to my application.

In the LiveCode standalone application settings dialog Windows tab I selected Windows 64 bit so it is a 64 bit application.

The folder layout of the application is as follows

Using Inno Script Studio I compile the script and that works with no problem.  
- I have a code signing certificate so the code is signed using the sign tool
- I looked at the “creating setup files message and I see that the external tsNet external is loaded.

Still when I try to launch my application I get a dialog titled ‘Initialization error’.  Its error message is ‘failed to load external: tsNet’

I thought it might be looking for the 32 bit version of the tsNet external, tsNet-x86.dll  so I added that to the Externals folder in addition to the 64 bit version that I already had before running the compiler again.   Same result.

I found a similar issue in the forums but the fix was to update to the stable version of LiveCode 9.5.0.

I am using LiveCode 9.6.0 so unless there has been a regression that should not be the issue.

Thanks in advance for any suggestions.

Best regards, 

Martin Koob

More information about the use-livecode mailing list