Mac Codesigning stops working. (revSecurity.dylib)

Matthias Rebbe matthias_livecode_150811 at
Sun Sep 29 17:55:56 EDT 2019

Hi Tony,

i just did a test with a small app like your test app  and AppWrapper and run into  a similar problem.
I then tried from shell and i got also an error. 

The error message contained among other text the following
"Agreeing to the Xcode/iOS license requires admin privileges, please run “sudo xcodebuild -license” and then retry this command."

I ran
sudo xcodebuild -license
in terminal and followed the instructions and agreed the license.

After that i was able to  codesgin my test app in AppWrapper again.



Matthias Rebbe

free tools for Livecoders:
InstaMaker <>
WinSignMaker Mac <>

> Am 29.09.2019 um 21:46 schrieb Tony Trivia via use-livecode <use-livecode at <mailto:use-livecode at>>:
> Hi all.
> I had the whole Mac codesigning thing under control, notarization, all
> that. Was successfully signing, notarizing and distributing (as third
> party) my MacOS app as recently as a week ago.  But about two days,
> AppWrapper 3 started reporting "Failed to sign" blaming the subcomponent
> revSecurity.dylib.  App Wrapper diagnosis says "code object is not signed
> at all in architectur: x86_64.
> My build is in LC 9.5 using 64-bit.
> I built a minimalist stack with one "go url" button to trigger inclusion of
> revSecurity and TSnet. Attempts to sign that minimal stack as a Mac
> standalone gets the same errors.
> Codesigning via Terminal also fails.
> Anyone else have this problem? Suggestions?
> Thanks!
> TT
> _______________________________________________
> use-livecode mailing list
> use-livecode at <mailto:use-livecode at>
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:

More information about the use-livecode mailing list