[ANN] Release 9.6.0 DP-1

panagiotis merakos merakosp at gmail.com
Thu Nov 28 15:56:55 EST 2019

Hello Brahmanathaswami,

Not sure which terminal commands you are referring to, maybe these:


1. Use the codesign tool to check the entitlements on the .app bundle:
Type in a terminal:

codesign -d --entitlements :- /path/to/yourApp.app

2. Use the security tool to check the entitlements of the app's embedded
provisioning profile:
Type in a terminal:

security cms -D -i /path/to/yourApp.app/embedded.mobileprovision

- Then see if there is an entitlement that is present in (1) but not in (2).

Now, regarding the crash you still get with mobileControlCreate, I would
suggest you file a bug report with a sample stack and audio file.

I had tested the new iOS player with both audio and video before releasing
9.6 dp1, with both local and remote files, and had no issues.

BTW I suggest you make sure the command line tools you use are the ones of
Xcode 11.1.

What is the output of this terminal command?

xcode-select -p


On Thu, Nov 28, 2019, 22:12 Sannyasin Brahmanathaswami via use-livecode <
use-livecode at lists.runrev.com> wrote:

> > =============
> > Your application failed code-signing
> > check. Check your certificates,
> > provisioning profiles, and bundles ids.
> > ================
> @Brahmanathaswami
> When do you get this error? When building the standalone, or when
> installing it to device?
> Regards,
> Panos
> --
> When try to install it to device, I thought worked before in 9.5.1 (rc 1)
> I looked over all your posts to the list and found one which suggest we
> use a iOS development profile
> So I made a new certificate and create a development profile, installed
> that and chose it from the SA panel.
> No go…. same error. Next I read the release note…. since XCode 10.1 was
> supported I tried that… 11.1,SDK 12.1 "green" - 10.1 SKD 12.1 now to "red"
> e.g. not accepted on mobile preferences. I went back to 11.1, and using the
> Development profile (I turned off "Beta Text") . I got the "intuition" that
> I should shut down after reboot. This time trying with the iOS development
> tool it went through and asked for a pass word to allow LC to use the
> certificate … (it is doing "sudo" in the background) I gave it my admin
> pass word and "always allows" and it installed on the phone. Yay!
> But to my "dismay" the mobileCreatePlayer causes the app to crash….  which
> was the whole purpose of my grade, to get audio work on iPhone 7 and 8…
> Anyway:
> If you installed Catalina. Don’t make the mistake in thinking that your
> KeyChain has been ported automatically. You should re-install your
> certificates, reboot, then things will start to work. (my guess)
> Meanwhile, can you post again the  terminal command for check the
> profiles. I have lost them somewhere and don't find them on the list.
> .
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode

More information about the use-livecode mailing list