iOS simulator not responding

panagiotis merakos merakosp at
Mon Nov 25 17:11:24 EST 2019

Hello Jacque,

So the iOS standalone is installed to the iOS simulator, but the simulator
does not respond to clicks / keyboard entry?

I am on Mojave as well, but have not seen that happening.

Maybe it is worth resetting the simulator state:
Quit any instances of Xcode and iOS simulator, and execute this in the

sudo killall -9

- Open the Simulator from Xcode (Launch Xcode 10.1, go to Xcode's menubar
and choose
Xcode -> Open Developer Tool -> Simulator)
- Wait until the simulator fully loads, until it shows the device's Home
If you change device by clicking on the Simulator's app menubar
(Hardware -> Device -> iOS 12.1 -> <device_name> ) - again, wait until the
new simulator device fully loads, until it shows the device's Home screen
- Now go back to LiveCode and test again

Fingers crossed :)


On Mon, 25 Nov 2019 at 21:43, J. Landman Gay via use-livecode <
use-livecode at> wrote:

> When I run a test on the iOS simulator, it will not respond to either
> clicks/taps or keyboard entry. Basically, it's inert. I've tried several
> different hardware devices, all with the same results.
> A Google search seems to show that this is a bug in the simulator when
> running under Mojave, and works again if run in Catalina. I can't update
> to Catalina yet because several apps I rely on will not run there.
> I'm using LC 9.5.1 (rc1), XCode 10.1, on Mojave. Has anyone seen this,
> and if so, have a workaround?
> --
> Jacqueline Landman Gay         |     jacque at
> HyperActive Software           |
> _______________________________________________
> use-livecode mailing list
> use-livecode at
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:

More information about the use-livecode mailing list